Инструменты пользователя

Инструменты сайта


Боковая панель

Связь

inkscape

Inkscape

Homepage: Inkscape

Inkscape (Инкскейп) — векторный графический редактор, бесплатный с открытым исходным кодом (лицензия GNU GPL). В качестве основного формата в программе используется стандарт SVG. Программа позволяет работать с контурами, фигурами, текстом, градиентами и импортированной графикой.

Поддерживаемые форматы документов:

  • Импорт: SVG, SVGZ, EMF, EPS, PostScript, PDF, AI (9.0 и выше), Dia, Sketch, PNG, TIFF, JPEG, XPM, GIF, BMP, WMF, WPG, GGR, ANI, ICO, CUR, PCX, PNM, RAS, TGA, WBMP, XBM, XPM.
  • Экспорт: PNG, SVG, EPS, PostScript, PDF 1.4 (с полупрозрачностью), Dia, AI, Sketch, POV-Ray, LaTeX, OpenDocument Draw, GPL, EMF, POV, DXF.
# aptitude install inkscape
  • Изменение масштаба. Проще всего изменять масштаб клавишами - и +. Также можно использовать щелчок средней клавишей мыши (Shift + щелчок уменьшает масштаб), или вращение колеса мыши с нажатой клавишей Ctrl. Еще можно ввести нужный масштаб в поле ввода в правом нижнем углу окна и нажать Enter. И наконец, на панели слева есть инструмент Изменение масштаба, при помощи которого можно изменять масштаб, обводя мышью нужную область.
  • Свойства документа (Shift+Ctrl+D). Можно изменить размеры холста, например, под содержимое. Установить сетку.
  • Инструмент редактирования узлов. Вызовите нажав F2. Вы увидите несколько серых квадратов на контуре — узлов. Эти узлы могут быть выбраны разными способами: щелчком мыши, Shift+щелчок или тянущимся выделением — точно так же, как объекты выделяются обычным инструментом выделения. Вы также можете щёлкнуть сегмент контура для автоматического выбора соседних узлов. Выбранные узлы становятся выделенными и показывают свои рычаги — один или два кружка, соединённых с выбранным узлом отрезком прямой линии. Контуры редактируются перетаскиванием своих узлов и рычагов управления. Вы можете вставлять узлы в любую часть контура двойным щелчком мышью или комбинацией клавиш Ctrl+Alt+Щелчок в нужной точке контура. Вы можете стирать узлы нажатием Del или Ctrl+Alt+Click. При удалении узлов программа попытается сохранить фигуру контура. Если вы этого не хотите, используйте комбинацию Ctrl+Del. Кроме того, вы можете продублировать выбранные узлы (Shift+D). Контур можно разорвать на месте выбранного узла (Shift+B), а разбив, соединить обратно, выбрав концы контура и нажав Shift+J. Каждый узел может быть острым (Shift+C) — это значит, что оба рычага узла могут двигаться под любым углом независимо друг от друга; сглаженным (Shift+S) — это значит, что рычаги узла всегда находятся на прямой линии и взаимно зависимы при повороте; симметричным (Shift+Y) — почти то же самое, что и сглаженные рычаги, но эти рычаги ещё и одинаковой длины. При смене типа узла вы можете сохранить позицию одного из двух рычагов, держа над ним курсор мыши, так что только один рычаг поворачивается/масштабируется до совпадения.
  • Редактор XML (Shift+Ctrl+X). Вы можете редактировать свои рисунки и смотреть на изменения в дереве XML или же наоборот вы можете редактировать любой текст, элемент или атрибут узла в XML- редакторе и видеть результат действий на холсте.
  • Файл> Импортировать (File > Import) (Crtl+I). Inkscape позволяет внедрить импортируемый файл в наш разрабатываемый svg- файл (действие по умолчанию). Или можно связать файл с нашим, в этом случае Inkscape не будет хранить копию файла внутри файла SVG, а сохранит только ссылку на импортируемый файл.
  • «Контур» > «Оконтурить» (Path > Object to Path) - можно преобразовать любую фигуру к контуру, но обратное превращение невозможно.

Инструменты

Выделение объектов

Выберите инструмент "выделение". Теперь щелкните по любому объекту на холсте. Вокруг объекта вы увидите восемь инверсных стрелок. Теперь вы можете:

  • перетаскивать сам объект мышью (нажмите Ctrl, чтобы двигаться строго по горизонтали или вертикали)
  • изменять размер объекта, перетаскивая мышью любую из стрелок (нажмите Ctrl, чтобы сохранить исходное отношение ширины и высоты).

Если щелкнуть по объекту еще раз, вид стрелок изменится. Теперь можно:

  • поворачивать объект мышью при помощи угловых стрелок (с нажатой Ctrl объект поворачивается на углы, кратные 15 градусам),
  • выполнять скос объекта с помощью не угловых стрелок.

Можно использовать поля ввода на верхней панели для установки точных значений координат (X и Y) и размеров (W и H) выделенных объектов.

С нажатой клавищей Shift выбираются несколько объектов. Esc снимает любое имеющееся выделение. Ctrl+A выделяет все объекты в документе.

Дублирование и Клонирование объекта

Дублирование объекта (Ctrl+D). Дубликат располагается точно над исходным объектом, становится выделенным, и можно сразу перемещать его мышью или клавишами со стрелками.

При создании дубликата объекта (дублировании) мы получаем точную копию объекта — его дубль. Каждый дубль при этом является вполне самостоятельным объектом, который в дальнейшем можно изменять произвольным образом. При этом произведенные изменения никак не отражаются ни на исходном объекте, ни на других дублях.

Иначе обстоит дело при клонировании.

Клонирование объекта — его точная копия, связанная с исходным объектом. Все изменения исходного объекта распространяются на его клоны. При этом изменения отдельного клона никак не отражаются ни на исходном объекте, ни на других клонах. Для клонирования объекта необходимо выделить исходный объект и выбрать в меню Правка пункт клон ‒ создать клон. Клон помещается над объектом и становится выделенным. Так же, как и дубликат, его можно перемещать при помощи мыши или стрелок.

Видоизменение клона никак не влияет на оригинал, но изменения оригинала, например размер объекта и/или цвет заливки, немедленно отражаются на клоне.
Из клонов можно создавать узоры. Для этого нужно выделить исходный объект и выбрать в меню Правка пункт Клон — Создать узор из клонов.

Логические операции над объектами

Команды в меню "Контур" позволяют вам объединять два и более объектов, используя логические операции. Операции Разность и Исключающее ИЛИ могут применяться только к двум выбранным объектам; другие могут применяться к любому количеству объектов. Получаемый объект всегда использует настройки стиля (заливки и штриха) нижнего объекта. Сумма сливает два объекта и делает из них один. Использование команды Исключающее ИЛИ выглядит похожим на команду Объединить , но разница заключается в том, что Исключающее ИЛИ добавляет узлы в местах пересечения изначальных контуров. Разница между командами Разделить и Разрезать контур состоит в том, что первая разрезает целостность нижнего объекта контуром верхнего объекта, в то время как вторая режет только штрих нижнего объекта и убирает заливку (это удобно для разрезания штрихов незалитых объектов).

Копирование стиля

Если стиль одного объекта (например, квадрата) нужно привести к стилю уже настроенного объекта (например, круга) нужно выбрать круг нажать Ctrl+C, для копирования круга. После этого выбираем квадрат и жмем Shift+Ctrl+V, чтобы применить стиль скопированного объекта. Вместо вставки в рабочее поле нового круга, стиль скопированного объекта будет применен на квадрате.

Слои (layers)

Слои (layers) часто используются для того, чтобы разделить части одного изображения на части. Все слои упорядочены относительно друг друга, поэтому один слой может быть фоном для другого и при этом скрывать третий.

Панель "Слои" вызывается клавишами Shift+Ctrl+L или можно использовать кнопки в нижней части интерфейса Inkscape.

Панель "Слои" позволяет сделать:

  • Можно выбрать слой щелкнув по его имени в списке слоев. С выбранным слоем можно работать.
  • Слой можно переименовать. Сделайте двойной щелчок на его имени.
  • Если щелкнуть на изображение глаза слава от имени слоя, слой можно сделать невидимым. Использовать можно и видимые и не видимые слои. Скрывая слой, мы получаем возможность работать со слоем лежащем ниже, так же можно скрывать слои созданные как черновики и для хранения комментариев!
  • Изображение замка левее названия слоя позволяет сделать слой не редактируемым и не выбираемым, говорят «запереть» слой. Это чрезвычайно полезно при работе сложными изображениями, так как в ходе работы будет накапливаться масса всего. Вы оставляете слой, которым работаете в данный момент редактируемым и блокируете редактирование других слоев, на случай случайно испортить что либо в них.
  • Кнопки стрелок внизу окна позволяют изменять расположение слоя относительно других. Можно перемещать слой по шагам в низ или вверх, либо переместить слой на самый верх или низ с помощью кнопок со стрелочками и чертой. Слой на верху списка, выше других слоев, слой в конце списка самый нижний.
  • Кнопки «Плюс» и «Минус» позволяют добавлять и удалять слои соответственно.
  • «Непрозрачность» (Opacity) позволяет менять прозрачность слоя, это очень полезно для всевозможный эффектов. Это так же полезно для слоев с рабочими заметками. Я предпочитаю использовать «Каллиграфическое перо» (calligraphic brush tool) в левой части экрана, в отдельном черновом слое. Тогда я могу взять слой целиком, сделать его частично прозрачным, переместить его на самый верх, затем заблокировать его. Таким образом я могу дорабатывать свой основной рисунок имея наглядное представление о новом слое.

Инструменты рисования

Прямоугольник

При помощи инструмента прямоугольники и квадраты можно построить прямоугольник, перемещая мышь по холсту и удерживая нажатой левую клавишу мыши. Если при этом удерживать нажатой клавишу ctrl, получится квадрат. Меняя на панели вверху параметры Горизонтальный радиус и Вертикальный радиус, можно получить квадрат со скругленными краями (то же самое, но с меньшей точностью, можно сделать при помощи круглых угловых маркеров). Для того чтобы отменить закругление объекта и вернуть его в исходное состояние (прямоугольник), можно нажать на панели свойств кнопку Не закруглен.

Эллипс

При помощи инструмента "круги, эллипсы и дуги" можно построить эллипс, перемещая мышь по холсту и удерживая нажатой левую клавишу мыши. Если при этом удерживать нажатой клавишу Сtrl, получится круг (удержание Ctrl сохранит пропорции фигуры такими, какими они были в начале, меняется только размер. Удерживая Shift+Ctrl мы изменяем размер круга от его центра, а не от противоположного угла.

Меняя на панели вверху параметры Начало и Конец, можно получить сегмент круга (то же самое, но с меньшей точностью, можно сделать при помощи круглых угловых маркеров). Установив флажок в поле Открыть дугу, можно превратить сектор в сегмент. Для того, чтобы вернуть объект в исходное состояние (эллипс), можно нажать на панели свойств кнопку Сделать целым.

Звезды и многоугольники

Перемещая мышь по холсту и удерживая нажатой левую клавишу мыши, можно построить многоугольник. Меняя на панели вверху параметр Отношение радиусов, можно получать различные фигуры, от выпуклого многоугольника (при значении, равном 1) до звезды с очень тонкими лучами (при значении, равном 0,1). Так же можно изменить количество углов и степень скругления. Каждый многоугольник содержит два ромбовидных маркера. Они позволяют изменять форму многоугольника различным образом. Например, можно получать интересные фигуры, вращая внутренний или внешний маркер вокруг центра фигуры.

Спираль

Инструмент "спираль" позволяет создавать простые и логарифмические спирали. На панели параметров можно изменить количество витков спирали, степень «раскрученности» (нелинейность) и величину внутреннего радиуса

Перо и Карандаш

Перо и Карандаш создают так называемые контуры. Контур — это последовательность отрезков прямых линий, и/или кривых Безье, которая как и любой другой объект в Inkscape может иметь собственные параметры заливки и штриха. В отличие от фигур контур может свободно редактироваться смещением любого из его узлов (а не только предустановленных рычагов) или перетаскиванием его сегмента.

Меню Текст

Текст можно расположить вдоль какой-либо кривой. Для этого нужно выделить одновременно нужный текст и кривую и выбрать в меню Текст пункт Разместить по контуру. Текст разместится по кривой, начиная от левого ее края. Для того чтобы снять текст с контура, нужно в меню Текст выбрать пункт Снять с контура.

Рекомендуется создавать специальную кривую для размещения на ней текста, это сделает работу более удобной. Например, вы можете сделать эту кривую невидимой.

Создание анимации в Inkscape

Ссылки




inkscape.txt · Последние изменения: 2012/01/06 10:19 (внешнее изменение)